MailZen for Android Client not available in the Google Play Store!

Incident Report for Soliton Systems Europe - Status

Resolved

Dear Customers and Partners,

Last night we were able to finally convince Google that we really are who we say we are ;-) It seems that the MailZen for Android is back in the Google Play for download. From our side this issue is resolved now!

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please submit them at: https://solitonsystems.atlassian.net/servicedesk or send us an email at: help@solitonsystems.com.

Thank you for your time and please stay healthy.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted Nov 26, 2024 - 12:54 CET

Identified

Dear Customers and Partners,

We have identified the issue (it is based on the DSA Validation Process) and working now on getting the app back into the Google Play Store. We keep you in the loop and will send updates as soon as they are available.

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please submit them at: https://solitonsystems.atlassian.net/servicedesk or send us an email at: help@solitonsystems.com.

Thank you for your time and please stay healthy.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted Nov 25, 2024 - 13:40 CET

Update

We are continuing to investigate this issue.
Posted Nov 25, 2024 - 10:19 CET

Investigating

Dear Customers and Partners,

We are currently experiencing issues with our MailZen Client in the Google Play Store. The Client is currently not available for download.
Our team is currently investigating this issue and we will provide regular updates. The next update will be provided at 13:00 CEST.

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please submit them at: https://solitonsystems.atlassian.net/servicedesk or send us an email at: help@solitonsystems.com.

Thank you for your time and please stay healthy.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted Nov 25, 2024 - 10:16 CET
This incident affected: Soliton MailZen Cloud Service - Europe (Mailzen for Android).