!!! Incompatibility issue found with MailZen for Android and Android 14 !!!
Incident Report for Soliton Systems Europe - Status
Resolved
Dear Customers and Partners,

We hope this message finds you well. Our team at Soliton wants to bring to your attention that we got finally the OK from Google to deploy our new MailZen for Android Client v8.8.2. This update will fix the problem with all the Google Pixel phones based on Android 14.

We are feeling sorry that it took us soooooooo long to get the new client certified by Google, but they have improved their testing process for Google Play and with that change, we were facing a lot of issues and challenges during the deployment.

So, on the 25th of March we are planning to release the new MailZen for Android v8.8.2 and also the new MailZen for iOS v8.94.1. If this sounds good to you... super! But there is a bitter pill you have to swallow ;-) We have also increased our security within the MailZen infrastructure and with that said, we are discontinuing with any connection based on TLS 1.0 and 1.1! This means, if your Exchange ActiveSync and EWS is able to handle TLS 1.2 connections with secure cipher suites, you are good to go and ready for the new clients. But if your users start updating their clients next Monday and complaining that a connection to your Exchange is no longer possible, the new clients could be the reason for that issue. Just check your certificate and the Windows settings to ensure TLS 1.2 with secure cipher suites are in place. If you need help with that, please get in touch with us!

Sorry for any inconvenience.
We appreciate your patience and understanding. As always, if you have questions or issues, please submit them at: https://solitonsystems.atlassian.net/servicedesk or send us an email to: help@solitonsystems.com

Thanks for your time and stay healthy,
The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Soliton MailZen Cloud Service - Europe - MailZen - Management Portal
Posted Mar 21, 2024 - 13:53 CET
Investigating
Dear Customers and Partners,

We hope this message finds you well. Our team at Soliton wants to bring to your attention an important matter regarding the Android 14 update in combination with MailZen for Android.

After careful consideration and testing, we have identified potential compatibility issues between Android 14 and certain features of our MailZen for Android application. These issues may result in disruptions, malfunctions, or loss of functionality if you choose to update your device to Android 14.

To ensure the optimal performance of our services on your mobile device, we strongly advise against updating to Android 14 until we release a compatibility update. Our development team is actively working on resolving these issues, and we anticipate having a compatible version ready for release in the coming weeks.

In the meantime, we kindly ask you to refrain from updating your device to Android 14. Disabling automatic updates on your device settings can help prevent any unintended installations.

We understand that timely updates are crucial for your device's security and performance, and we sincerely apologize for any inconvenience this may cause. Rest assured that we are committed to providing you with a seamless experience, and we appreciate your understanding and patience as we work to address these compatibility concerns.

Sorry for any inconvenience.
We appreciate your patience and understanding. As always, if you have questions or issues, please submit them at: https://solitonsystems.atlassian.net/servicedesk or send us an email to: help@solitonsystems.com

Thanks for your time and stay healthy,
The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Soliton MailZen Cloud Service - Europe - MailZen - Management Portal
Posted Dec 22, 2023 - 13:45 CET