MailZen Cloud v2.59 - On-Boarding issue with iOS and Android App!

Incident Report for Soliton Systems Europe - Status

Resolved

Dear Customers and Partners,

We have been monitoring the issue for some time, and the time-outs are gone. That's the good news. The not-so-good news is that some customers need to update their gateway to Version 1.54 if they are connected to our cloud portal. The reason is that the ACL protocol has changed, so older versions can't update the ACLs or retrieve the initial set of ACLs during onboarding.

You can easily perform an in-place update with the following commands:
# wget https://install.solitonsystems.com/mailzen/gw/1.54/libsera_7.49.1_amd64.deb
# wget https://install.solitonsystems.com/mailzen/gw/1.54/sera-gateway_1.54.0-1_amd64.deb
# dpkg -i libsera_7.49.1_amd64.deb sera-gateway_1.54.0-1_amd64.deb.

Our team is available if you need help with the update or experience issues afterwards. We will also identify customers with outdated gateways and reach out to them proactively.

We apologize for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please visit https://solitonsystems.atlassian.net/servicedesk or email us at help@solitonsystems.com.

Thank you for your time, and please stay well.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted May 28, 2025 - 11:19 CEST

Monitoring

Dear customers and partners,

We have released a new version of our MailZen Cloud Portal and it seems that request timeouts are much less frequent now. As we said before, only overseas customers with high latency were primarily affected by this issue.

We will monitor the situation over the weekend and if we don't see any more problems we will close this incident on Monday morning around 10:00 CEST.

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please visit https://solitonsystems.atlassian.net/servicedesk or email us at help@solitonsystems.com.

Thank you for your time and please stay well.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted May 23, 2025 - 11:50 CEST

Identified

Dear Customers and Partners,

We have now noticed that customers who experience high latency when connecting to our portal are more affected by this issue than others. We are now going to increase the timeout per request and see if this fixes the problem. This may not be a permanent fix, but we think it may at least reduce the problem.

There will be a short downtime of our MailZen Cloud for around 15 minutes at 10:00am CEST!

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please visit https://solitonsystems.atlassian.net/servicedesk or email us at help@solitonsystems.com.

Thank you for your time and please stay well.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted May 23, 2025 - 09:44 CEST

Update

Dear customers and partners,

It seems that this issue is related to configuration and trusted CA list updates from the new portal. We have seen in the logs that devices are not able to pick up configuration changes and also the transfer of the list of trusted CAs fails several times in a row and then sometimes works! We have decided not to revert to the previous version 2.58 because the impact is small and only a few customers have recognized it so far. Sometimes it helps to start the onboarding several times and try again until it works!

Our team is still investigating this issue and we will provide regular updates. The next update will be at 17:00 CEST.

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please visit https://solitonsystems.atlassian.net/servicedesk or email us at help@solitonsystems.com.

Thank you for your time and please stay well.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted May 22, 2025 - 14:39 CEST

Investigating

Dear customers and partners,

After updating to v2.59 we are currently experiencing issues with our MailZen Cloud Service. Users attempting to activate a new iOS/iPadOS or Android device are getting stuck during the authentication process, resulting in the activation process not completing or an "NT400" error. However, devices that have already been activated are working properly.

In particular, customers with MailZen Enterprise Gateways should verify that new users/devices have been successfully provisioned and that the device is functioning as expected. If you experience any problems with the onboarding process, please notify our support team!

Our team is currently investigating this issue and we will provide regular updates. The next update will be at 13:00 CEST.

We apologise for any inconvenience this may cause and thank you for your patience and understanding. As always, if you have any questions or concerns, please visit https://solitonsystems.atlassian.net/servicedesk or email us at help@solitonsystems.com.

Thank you for your time and please stay well.

Sincerely,

The Soliton Systems IT Service Management Team
_____________________________________________
SOLITON SYSTEMS EUROPE N.V.
Barbara Strozzilaan 364 | 1083 HN Amsterdam | Netherlands | P: +31 (0) 20 896 5841 | www.solitonsystems.com
Posted May 22, 2025 - 11:00 CEST
This incident affected: Soliton MailZen Cloud Service - Europe (Mailzen for Android, MailZen for iOS).